PDA

View Full Version : Problem with Local Network /Logitech Media Server



RichardFlack
November 7th, 2018, 01:04 AM
This is a bit difficult to describe precisely, but hoping someone can give me some pointers.
When I first used FB2Km (is that an ok abbreviation?) on my iPad, I was pleasantly surprised to see my desktop Logitech Media Server listed under Local Network. It was just there - and it worked, I could play songs off my desktop.
Then a few days later it disappeared.

My problem is that Im no sure what I did (if anything) for it to appear or disappear. The one thing that is probably relevant is that for a number of reasons I would have been switching networks on iPad and desktop ( i have 2 basically, with 2.4 and 5g on each of course and also a range extender).
I have tried all combinations of the networks on desktop and ipad but nothing seems to bring it back.

One thing that is odd, is that when I look in the LMS info it shows its IP address as fixed regardless of which network (router) the desktop is on. But specifically putting the ipad on the same network doesnt help.
Also if I put the IP address for LMS and port 9000 into the User-Specified Servers list explicitly, that doesnt work either.

FTP server (using Filezilla client) works just fine.

Does any one have any ideas?

RichardFlack
November 7th, 2018, 01:29 AM
Problem solved!
On a whim, as they say, I stopped and re-started LMS (after getting desktop and ipad onto the same server / router). That did the the trick, the LMS IP address changed (which it didnt do on simply reconnecting the desktop) and FB2Km now sees it. Dont know why I didnt think of that sooner (in the spirit of Zen and the Art of Motor Cycle Maintenance!).
Im not clear why this is necessary... wouldnt LMS know that the network it was connected to has gone away? Is this in fact expected behaviour?

Any way, problem solved. Im leaving this here in the remote event that it helps someone else.