PDA

View Full Version : W10M version feedback



kaum
February 13th, 2016, 07:30 AM
Windows 10 Mobile is out and a dedicated Windows 10 app for beta testing is available - so a separate thread is warranted IMHO.

kaum
February 13th, 2016, 08:01 AM
Foobar 1.0.6 beta crashes when I do "Save to tags" in ReplayGain Data when lock screen is opened and I unlock the phone.

L950 with W10M 10586.29

kaum
February 15th, 2016, 01:26 AM
Yesterday I got an update to Windows Store package version 1.3.2: Now when I go to Playback and press the three Menu dots Foobar crashes.

Peter
February 15th, 2016, 08:42 AM
Thanks for the reports, the issues are being addressed now.

Peter
February 15th, 2016, 09:21 AM
As for starting an operation such as saving tags and then locking the device-

This is a common scenario that phone operating systems do not like, as the app has been asked to minimize resource usage yet continues to do its workload. I made it cancel the operation cleanly upon suspend, but you will have to resume saving tags manually.

LanX
February 18th, 2016, 08:35 AM
Really strange... I've been allowed by Microsoft Store to download and install updated Windows 10 PC version (1.0.7 beta - x86 64-bit - Windows Store package version: 1.3.3) but it won't get updated for Windows Phone 10.
I tried to completely uninstall the app from my Lumia and then go back to the Store, but it keeps saying foobar2000 beta is not currently available and the download button is disabled.

kaum
February 18th, 2016, 09:56 AM
Really strange... I've been allowed by Microsoft Store to download and install updated Windows 10 PC version (1.0.7 beta - x86 64-bit - Windows Store package version: 1.3.3) but it won't get updated for Windows Phone 10.
I tried to completely uninstall the app from my Lumia and then go back to the Store, but it keeps saying foobar2000 beta is not currently available and the download button is disabled.
My guess is that you best go to the Store app and search in the "My library" for foobar beta. I think you can install it from there. You cannot get it from a normal store search. Login with your Microsoft account is required I guess.

kaum
February 18th, 2016, 09:58 AM
I tested it and I even got the 1.08 update (1.3.4) - great swiping again ;-)

LanX
February 18th, 2016, 10:50 AM
I don't have to install... but get the update.

As I previously said, desktop Windows 10 version got updated flawlessly:

4647

As you can see, I can access the Store page and see the Purchase/Download/Update button which is active and working.
I can also see foobar2000 in my available download list, but.....

48

... I cannot install/update in my Lumia from Windows Phone 10 Store because the button is disabled and the update doesn't appear in the available downloads/updates list.

(of course, I'm using the same account on both desktop and mobile Stores)

kaum
February 19th, 2016, 11:33 AM
Hi LanX, strange. Sorry to hear that. This workaround worked for me at least - last time I had the same problem with a different app...

Aelius
March 29th, 2016, 06:31 PM
Hello! The internal podcast app downloads content to Music\Podcasts. Could we implement a way to ignore that? Thanks.

Where might I find a changelog for new releases?

kaum
March 30th, 2016, 01:48 AM
Changelog? Have a look at http://forum.foobar2000.com/forum/showthread.php?64-Development-blog

randal1013
April 29th, 2016, 07:12 AM
On the desktop: items on the right side are a little tight with the scroll bar.

http://i.imgur.com/VZaeMcu.png
http://i.imgur.com/HRse2ea.png

randal1013
April 29th, 2016, 08:10 AM
I just drove to work and tried to use foobar. It does not work well over Bluetooth. The playback has an extreme stutter, like eh oh ch er eh oh er ch a... And the meta data didn't display the album title on the console. I have a Lumia 1520 windows phone, and my car is a 2014 Honda accord.

randal1013
April 29th, 2016, 07:37 PM
^my phone is running windows 10 mobile, 10.0.14332.1001

QueueJumper
May 1st, 2016, 05:15 PM
Is this the correct place to provide feedback on Win10M Public Preview version?

At first foobar2000 runs ok on my Lumia 950 XL.

Then I loaded more (4000+) songs on my MicroSD card's Music folder, run Groove music for once, test some of the new songs.
Then switch back to foobar2000, the app just stuck, can't control anything within seconds.
and the phone is getting pretty hot, killing foobar2000 and re-opening it won't help, even after rebooting the phone, foobar2000 still stuck the time I opened it.
Uninstalling foobar2000 and reinstalling it from the windows store, and re-indexing music library in foobar2000 seems resolved the issue.

Then some suggestion:
Album art: the album art displayed when playing seems not from the file, I've tried an album with 10+ discs (each disc have different album arts), the arts are all the same.
App tile: only showing foobar2000 icon. Take MS's groove music as an example, when playing its tile will display and switch info between the song's info (song title, artist, year, genre) and the album art. This way of displaying info is useful and unique, and considerably easy to implement?
Playlist: I think this is difficult to implement, but what I want to achieve is: I have every songs to have the <BPM> tag, I want to play a list of songs which %BPM% are between 120 and 140, for running exercises. Seems this scenario is not possible still, can't figure out how to achieve that on mobile phone, or work around it using a playlist.

Thank you for making UAP version, although the functionality is restricted comparing to the win32 version, it still surprises me with so many settings and possibilities!

kode54
May 1st, 2016, 10:46 PM
It's not unusual for Windows Phone versions to take several minutes or more to index a 500 song library, never mind a 4000+ song library. And we're not entitled to ask Microsoft how they make their music application so much faster. All file accesses to places like that require the use of horrible transactional file API, which slows things down considerably. The same libraries index in a tenth of the time on iOS and Android devices with similarly powered processors and fast storage.

QueueJumper
May 2nd, 2016, 12:27 AM
Thanks for the prompt reply.
I'm using a U3 MicroSD card with sequential read speed > 80MB/s, actually indexing 4k+ songs in both Groove Music and foobar2000 are pretty fast.
The problem is after indexing in the Groove Music, foobar2000 hangs even after reboot, and the phone seems doing a lot of cpu-heavy actions making it really hot. There's no procmon or procexp in mobile phone, I don't know how to monitor those things on the phone. I'm just suspecting it's related to how foobar2000 is scanning the updated system built-in music library, or the indexing in Groove Music is not really done yet when I opened foobar2000, thus causing problems.

J-Szymala
May 2nd, 2016, 06:42 AM
Hi,

I've installed foobar mobile on my Lumia 930 (Windows 10). The most annoying issue is that I can't listen to music when screen goes off - it simply stop playing (same like for example VLC Player).

T'nyr
May 2nd, 2016, 11:38 PM
Hello!

I noticed that it picked up my AMF tracker files when browsing my indexed files. :D

Is there a complete listing of all file formats that are supported/to be supported?

Cheers!

Peter
May 5th, 2016, 07:53 AM
Hi,

I've installed foobar mobile on my Lumia 930 (Windows 10). The most annoying issue is that I can't listen to music when screen goes off - it simply stop playing (same like for example VLC Player).

Please do not change sound output settings. The symptoms you're describing, it's what happens if you change the default MediaStreamSource to XAudio2 - which is broken on phone devices. The setting is provided for research and troubleshooting purposes only, use the defaults unless you really know what you're doing.

J-Szymala
May 7th, 2016, 09:14 AM
Please do not change sound output settings. The symptoms you're describing, it's what happens if you change the default MediaStreamSource to XAudio2 - which is broken on phone devices. The setting is provided for research and troubleshooting purposes only, use the defaults unless you really know what you're doing.

Hi,

thanks for answer. I've changed back to MediaStreamSource but now I can not play anything (via BT headphones) - these are errors which I receive every time I try to play music:

http://s32.postimg.org/u2xh42b9d/wp_ss_20160507_0001.jpg (http://postimg.org/image/u2xh42b9d/) http://s32.postimg.org/3s2xb84g1/wp_ss_20160507_0002.jpg (http://postimg.org/image/3s2xb84g1/)

J-Szymala
May 7th, 2016, 09:16 AM
Please do not change sound output settings. The symptoms you're describing, it's what happens if you change the default MediaStreamSource to XAudio2 - which is broken on phone devices. The setting is provided for research and troubleshooting purposes only, use the defaults unless you really know what you're doing.

Hi,

thanks for answer. I've changed back to MediaStreamSource but now I can not play anything (via BT headphones) - these are errors which I receive every time I try to play music:

http://s32.postimg.org/u2xh42b9d/wp_ss_20160507_0001.jpg (http://postimg.org/image/u2xh42b9d/) http://s32.postimg.org/3s2xb84g1/wp_ss_20160507_0002.jpg (http://postimg.org/image/3s2xb84g1/)

Maestro
May 7th, 2016, 12:54 PM
I just drove to work and tried to use foobar. It does not work well over Bluetooth. The playback has an extreme stutter, like eh oh ch er eh oh er ch a... And the meta data didn't display the album title on the console. I have a Lumia 1520 windows phone, and my car is a 2014 Honda accord.

I have the same issue on my 950 playing to my wireless headphones. Playback was fine for a second but then started having crazy stutter.

PeterPan
May 16th, 2016, 05:29 AM
I also experience the problems with playing music via Bluetooth (I am using Philipps Headphones).

Second thing I noticed, is the variation in the volume:
If I choose 'Shuffle All Tracks' there is a big difference in the volume of the tracks.
I assumed that the reason might be the ReplayGain. So I changed it to 'track'. But I couldn't notice any changes.
Is it necessary to load the library again so that the changes in the ReplayGain are applied?
Or is there another reason for that issue?

Gwystyl
May 16th, 2016, 07:07 PM
I have the same issue on my 950 playing to my wireless headphones. Playback was fine for a second but then started having crazy stutter.

I am likewise having the same problem with my Lumia 640XL with version 1511, build 10.0.10586.218 (planning to update to 10.0.10586.318 tonight, we'll see if it helps..) I haven't had any issues with the player other than the bluetooth, and I'm ecstatic about it's existence since Groove is really a horrible program on Win10M!

The GUI is excellent, it's fast and responsive, and has a lot of control and options for ensuring how it is supposed to function!

One of the things I'd like to see (and maybe already exists?) is the ability to create a playlist on my Win10 desktop and have it sync? That would definitely be sweet. However, the bluetooth thing is pretty curcial.. I have a JBL Clip, which is awesome, and I like having the speaker away from the device. It does have a cord, about 8" or so, which I can use without issue through the headphone output of the phone. But when I try to play songs with it connected to bluetooth it stutters and freezes, ultimately telling me that it can't be played :( I know it's not a system issue because the phone connects right up, and there are no issues using the Clip with either the phone, or the Groove player.

So any ideas on how to fix this, or if a solution is being worked on for an update?

Gwystyl
May 18th, 2016, 05:42 PM
I am likewise having the same problem with my Lumia 640XL with version 1511, build 10.0.10586.218 (planning to update to 10.0.10586.318 tonight, we'll see if it helps..) I haven't had any issues with the player other than the bluetooth, and I'm ecstatic about it's existence since Groove is really a horrible program on Win10M!

The GUI is excellent, it's fast and responsive, and has a lot of control and options for ensuring how it is supposed to function!

One of the things I'd like to see (and maybe already exists?) is the ability to create a playlist on my Win10 desktop and have it sync? That would definitely be sweet. However, the bluetooth thing is pretty curcial.. I have a JBL Clip, which is awesome, and I like having the speaker away from the device. It does have a cord, about 8" or so, which I can use without issue through the headphone output of the phone. But when I try to play songs with it connected to bluetooth it stutters and freezes, ultimately telling me that it can't be played :( I know it's not a system issue because the phone connects right up, and there are no issues using the Clip with either the phone, or the Groove player.

So any ideas on how to fix this, or if a solution is being worked on for an update?

For the record, upgrading to 10.0.10586.318 did not fix the problem, the bluetooth still freezes and crashes the player.

KEN
May 21st, 2016, 06:13 AM
Hi :)

foobar2000 Universal Windows App Version 1.0.23 (2016-05-20)

Tools>SETTINGS>Choose Skin>"ADD MORE>Open..."

"ADD MORE>Open..." cannot be found.

Thanks.

KEN
May 23rd, 2016, 08:45 AM
Someone help please.:(

Version 1.0.23 - X
Version 1.0.22 - no problem

elgobuda
May 26th, 2016, 09:00 AM
Really good app in terms of audio playback and most importantly the ID tags are read properly and there is gapless playback!

But what about a live tile? Also, can't the tile icon be a bit better looking?

Another thing, is navigation, isn't it possible to have a direct shortcut back to the library? If I selected an album to play, and I swipe to the right, I get back to the song view and then I have to press back to get to the library view?

Finally, can't there be an option to have the app auto hide the nav bar when I open it?

hst
May 26th, 2016, 12:21 PM
Hello,!

I installed foobar 2000 mobile. But can't seem to use tracks repeat and playlists repeat, I'm looking for a long time in the settings, it seems there is no repeat settings, it can only be set to play the next song, so foobar2000 can not set the repeat play?:confused:

My phone is Lumia 638,Windows 10 Mobile 10.0.10586.318

Thanks for any answers and solutions!

kaum
May 27th, 2016, 12:49 PM
Hello,!

I installed foobar 2000 mobile. But can't seem to use tracks repeat and playlists repeat, I'm looking for a long time in the settings, it seems there is no repeat settings, it can only be set to play the next song, so foobar2000 can not set the repeat play?:confused:

My phone is Lumia 638,Windows 10 Mobile 10.0.10586.318

Thanks for any answers and solutions!

Looks like you hit a missing feature here. I have not found it either on the first glance.

ZarkBit
May 27th, 2016, 09:14 PM
Hello,!

I installed foobar 2000 mobile. But can't seem to use tracks repeat and playlists repeat(...)



Been looking for this also, searched all over the place and nothing.

Windows 10 Mobile 10.0.10586.318
Nokia Lumia 630
foobar2000 mobile v1.0.23 lite

Kljunas
May 31st, 2016, 02:20 PM
The volume is too loud. I set gain all the way down to -12dB but it's still louder than Groove Music (tried on volume 1). Doesn't seem to be affected by equaliser settings either.

I'm on a Lumia 640 if this is of any relevance.

paradajz
June 2nd, 2016, 02:35 PM
Version 1.0.25/1.0.26, 2016-05-31.
Output method is now WASAPI shared mode, on all devices. Necessary resampling is performed automatically.

I assume this is why the audio on my Lumia 820 running latest W10 (release ring) now glitches like crazy. I thought my audio jack is broken, but audio works perfectly in any other app.

Rootdown4594
June 5th, 2016, 07:30 PM
I'm also experiencing slight sporadic glitching as if the buffers are too small.

Peter
June 6th, 2016, 04:03 AM
Thanks for all the bug reports.

WASAPI worked fine on all my 3 Lumia units, but apparently that's not good enough. I'm investigating this issue now. If you're experiencing glitching, please report exact phone model and OS version.

Peter
June 6th, 2016, 05:30 AM
The glitching, is there a pattern to it? Does it vary with audio file type being played? Does it glitch less when playing plain WAV or FLAC compared to MP3?

Rootdown4594
June 6th, 2016, 10:31 AM
For me the glitching is very slight and doesn't happen very often.

My files are OGG. The slight glitching seems to happen more while I'm using my phone(various apps and internet). Slight stutters. The same as if the buffers are too small. Don't have any other type of file on my phone right now to test, sorry.

Lumia 640
Windows 10 mobile 10.0.14342.1004

My phone just updated last night and I haven't used foobar since then. Not sure if the glitching is present on the new build my phone just downloaded.

Peter
June 8th, 2016, 08:55 AM
OK, the problem was that we were not getting enough of phone CPU's attention if another application was using all of it. Frankly Windows Phone kindly disregards standard thread priority manipulation routines of Win32 API, doesn't support classic Multimedia Class Scheduler Service methods, but provides a completely separate new thing as a replacement.

The good news is that I made foobar2000 mobile use the proper API for thread priority management and starting from the next update these stutters should be gone.

Michael Sargent
June 8th, 2016, 09:52 AM
Thanks Peter. The stuttering hasn't been too bad on my phone, but it will be nice to hear it gone.

Mike

Kallisticker
June 20th, 2016, 07:27 PM
Version 1.0.29 runs very well on my Lumia 1520, OS 14367.0.
Now I can even stream Internetradio stations via m3u or pls reliably, something none of the long existing apps like TuneIn or Rad.io managed to do.

Still some suggestions:
1. For an UWP app, the design could be more streamlined, i.e. following the guidelines (But I think you're priority was the functionality - and I'm absolutely fine with this).
2. Use the possibility to pin elements, like albums, playlists, probabaly even single files (It would be great if I was able to pin .m3u files to the startscreen to start radio stations directly).

I think you're on a pretty good way to provide a desktop-like Foobar experience on Windows 10 Mobile!
Keep it up!