PDA

View Full Version : Media Library dis-functionality and other observed bugs...



Coolhand
July 21st, 2016, 04:53 AM
Firstly I have reposted this more completely here as I inadvertently posted it in the IOS download guide Sticky (mods please delete it from there)...

With some further exploration of this incredibly cool app I found that the music which is downloaded from locally networked storage using it, resides within the Documents folder under the Media Library menu, and as such is not available to any other iOS music player applications.

Initially I found this to be a serious shortcoming, however my girlfriend pointed out a positive benefit of having a separated Foobar2000 Documents folder for music.
By having the music inside the Documents folder unique to Foobar2000 access ensures that when a user tools around with their iTunes updates of music, and it deletes music already on your iPhone (as it does by default when adding new music)... then you wont inadvertently delete music as the music contained within the Foobar2000 Documents folder is completely separate from that of the iTunes files structure.

What I would like to propose then, in order to keep this functionality (or independence from iTunes and its damn foibles !) whilst adding universal music player app flexibility, is for the developers to add an additional option to the Media Library menu whereby the user can select "Copy or Move to iTunes Library" for any tracks or albums which are in the Documents folder.

This would allow the user to selectively copy or move tracks or albums into the iTunes library repository on the iOS device, which will then allow other applications such as the Apple Music App, or Onkyo HF Player app etc... to also have access to music which has been downloaded from within the Foobar2000 app.

Perhaps more pressing an issue is the bug whereby the downloading of files from locally networked storage is frequently not functioning correctly as follows:
An album is seen on my Asset server and downloaded to my iOS device, selecting it from within the Documents folder displays the entire album track list and its artwork, however once selected for playback the artwork is no longer displayed and each track only plays for a couple of seconds before skipping to the next and doing the same until all have been momentarily played.
Worse behaviour is observed if one tries to play the album from within the default Browse, Album view.. here the same album is visible but opening it displays only a single track, and in this instance the artwork is displayed and the single track plays normally although both the album and artist are listed as Unknown ?!?!

This exact issue has been occurring with many albums that have been downloaded to my iOS device from my Asset server, the albums are not of a resolution beyond 44.1khz and are Aiff types (I have observed that Foobar2000 does not always play most higher resolution files correctly or at all, and they are all down-sampled to 44.1 irrespective of the DSP or High-Res Playback menu settings in Foobar).
These problem albums play without issue from Asset to my usual renderer/endpoint, so the issue is unique to the Foobar2000 iOS handling of them.

If any more detailed info or log files are required I would be glad to be of assistance to further aid the development of this unique and very useful application ;-)