PDA

View Full Version : Not for iOS 6 anymore?



nwn
October 11th, 2016, 03:20 PM
Hi,

today I tried to update foobar2000 on my iPod touch 4G with iOS 6. Unfortunately, I got a popup which asked me to upgrade to iOS 8 or higher for getting the newest version of foobar2000.
That's not part of the deal! I'm sad.

In December I donated some euros for developing a foobar2000 app for - and this was declared, at least iOS 6!

I installed it on my iPhone SE now - runs good, but this is not the device I'm using for music.

A few weeks ago, I thought about donating again, but sorry guys, I won't support this project anymore becaused you stopped supporting iOS 6.

Bye and thanks for the current version!

Peter
October 12th, 2016, 03:00 AM
I am very sorry to hear about your troubles.

I've just verified it on my own iPod Touch 4Gen, installing from appstore still works, except you get the last supported version. There are no known critical bugs in that version at the moment.

If it was up to me, I'd continue to support it, as all the code needed to support it is there.

Unfortunately, Apple dropped iOS 6.x target support in Xcode 8, so I'd have to be eternally stuck with an old unsupported version of the development chain in order to support old devices that a small fraction of our userbase uses - sadly this is not what I want.

I can probably still recompile using older Xcode - except iOS 10 specific stuff will break instead.