View Full Version : Foobar2000 Mobile not showing all music files

May 17th, 2017, 09:35 PM
Using Foobar2000 on an iPad or Samsung androiad phone.
Music is FLAC lossless ripped via DBPoweramp and stored on a NAS.
Can use other apps scan music files and all play with no problems using same NAS and FLAC files. ie mconnect or 8Player or Neutron etc.
When using Foobar2k I select the NAS as my media server and select the folder where the FLAC music files and use the by folder option.
Consistently the only files loaded are from artists A thru E does not go any further.
Any ideas as to what may be the problem here or am I doing something wrong.
Up to date version of iOS and Foobar2k as well as my Samsung phone.
Have the same issue when trying this at a friends using their iPad and their NAS.
I would like to use Foobar but it has been frustrating me.
Number of tracks in music collection approx 41000.

May 18th, 2017, 01:59 AM
Perhaps related to my problem:

May 18th, 2017, 05:28 AM
What NAS type is it?
Any specific media server software running on your NAS?

I presume you're using the NAS as UPnP server - auto discovered by foobar2000 mobile in Media Servers list without having to manually add anything.
If your NAS supports FTP shares, you can manually enter the ftp://username:password@hostname/ address in Settings / Media Servers, which will provide an alternate way to browse your NAS content, hopefully without bugs.

May 19th, 2017, 08:45 PM
Anyone with any ideas or experiencing the same issue?
Consistently only loads folders ( music is in folders by artist ) from A Perfect Circle thru to Eurogliders.
Always stops at Eurogliders. Next listed folder is Eurythmics in my FLAC file but Foobar2000 does not load this.
NAS is Seagate Personal Cloud. 1.8 TB of FLAC.
Foobar2000 can see the NAS and I can drill down to the music folder. Just does not load all.
A lot of albums. Can play any of album from folders A thru to Eurogliders
Unfortunately it leaves out all folders after this all the way to the last which is ZZ Top.
Have tried changing / experimenting with various settings in Foobar2000 mobile to no avail.
I also have the same music in ALAC format ( about 1.2TB ) on another NAS that has the same issue.

All music ripped via DBPoweramp using the following settings:
[IFVALUE]album artist,[album artist],[IFCOMP]Various Artists[][IF!COMP][artist][][]\[album]\[track] [artist] - [title]
with DSP effects: RG Replay Gain, HDCD, Folder.jpg folder preserve.
Hopefully something simple...:confused:

May 20th, 2017, 01:22 AM
Foobar2000 Mobile is Version 1.0.67 lite
iPad Mini iOS is 9.3.5 (13G36 )
Also decided to try the PC ( Win 10 ) version of Foobar2000 ( version 1.3.15 ) and loaded the same FLAC file. Seems to
find all the artists/albums from A to Z no problem.

May 23rd, 2017, 02:23 AM
Thanks for the responses so far.
Removed the Foobar2000 mobile app from the iPad Mini.
Same issue.
Could it be that I am using a Seagate Personal Cloud ( tried it on a Seagate Central as well..same issue )??
Strange given the other music apps like mconnect or 8player have no such issue.
Even running Foobar 2000 on a PC using the same NAS has no issue.
Do not seem to be able to use the ftp method although I may be setting it up wrongly but surely DLNA or UPnP should work..
Shame since I do like using it when I've played the albums it can see but unfortunately I would like to be able to choose anything within my entire library
not just a third of them.

May 24th, 2017, 08:12 AM
Perhaps there is a limit on how many items they serve per request - since they appear to give you first N items only. Foobar2000 mobile currently tries to get them all in one pass, instead of loading incrementally like some other clients do.

I'll attempt to fix this for the next foobar2000 update.

May 24th, 2017, 01:34 PM
Added attempted fix in version 1.0.76. You've been added to iOS beta testers, you will be able to install 1.0.76 beta through the testflight app when it gets approved. Please report back if it helps once you get it.

Edit: I presumed that your Apple account name is the same as your email address used for forum registration. If it is different, please drop me a private message the correct address to add.

May 24th, 2017, 06:10 PM
v1.0.76 beta loads all the music files via DLNA off the NAS. Only thing I had to do was redo all the settings.
Will play music via Foobar2k mobile and see how it goes.
Works with both the Seagate Personal Cloud that has lossless FLAC and the Seagate Central (that has the same number of artists/albums except that it is in lossless ALAC format).
All my music files were ripped via DBPoweramp into 3 formats at the same time..FLAC, ALAC and LAME320kbps. LAME for the car. Why I did multiples...good idea when I started..:rolleyes:
So far so good.
Any chance of a v1.0.76 for my Samsung android phone and see how that goes?
Many thanks.

May 25th, 2017, 01:03 AM
Thanks for confirming.

I've added you to Android beta as well - go to http://foobar2000.org/test-android to start receiving Android betas.

May 25th, 2017, 07:28 PM
The android version now shows all the files from A to Z.
Problem is that when playing the music is cutting in and out every 10 or so seconds.
Do not remember doing that last time I used it before upgrading to the beta version.
Testing done with the phone or iPad within 1 or 2 metres of the bluetooth speaker out of the way of any possible interference.
Phone I use for music playing if not using iPad is:
Samsung S5 model SM-9001I
Android version:6.0.1
Tried it on another S5 with the same result at v1.0.71
Other player (mcoonect player v2.2.2) on the same phone is working ok.
Mostly I use iPad for music playing to bluetooth UE Megaboom speakers ( via Foobar2k mobile now ).
When using my main traditional hifi stereo I use the iPad to control music by Bluios or JRiver remote.
These days using the flexibility of the portable bluetooth speakers more and more.
One other observation with Foobar2k is in the sorting of track order with both iOS and android.
When selecting music by Album the track order is numerical but when selecting by Folder the track order is alphabetical.
Some albums you just want to play as they were laid down in track order but given I like to use the Folder source a choice of track order either numerical or alphabetical would be good.
Be nice if you could select how you wanted to sort track order , for me anyway.
And while on the wish list...
1.A way of searching the music folder / source for a particular track name would be very helpful..mainly for those times when someone asks "have you got this obscure track".
2.Presenting the composer names in the skin would be great for people like myself who have painfully gone to the bother of checking / adding composers before ripping.
The iOS version on the iPad Mini still seems fine so I'm pretty happy.
Thanks again.

May 26th, 2017, 06:13 AM
Android audio dropouts-
Does it also happen when playing through phone's internal speaker or wired headphones instead of bluetooth?
Go to Advaned settings, toggle "Use OpenSL". This will hopefully work around the issue.

Regarding sorting and searching for a specific track, there's the search icon at the top when browsing music already.

Composer info present in the skin, noted.

May 26th, 2017, 06:50 PM
Problem still with phone on its own using internal speaker with or without OpenSL set.
Tried a variation of settings.No change.
Current Settings used ( essentially the same as with the iPad except for settings that do not exist with the iOS version.
only Skip silence is on all others off

Advanced: All on except the following are off:
Start playback when plugging headphones
Extract disc number
Sort albums by date
Show non audio files
Hide duplicate tracks

Replay Gain:
Source Album
Processing Gain
Pre Amp 0dB

Playback Order:

May 27th, 2017, 12:29 AM
No versions beyond 1.0.55 lite are reading any music files on my sd card. Using a Logic Gfive with 4.2.3 unrooted. Any suggestions?

May 29th, 2017, 08:34 AM
Problem still with phone on its own using internal speaker with or without OpenSL set.
Tried a variation of settings.No change.
Current Settings used ( essentially the same as with the iPad except for settings that do not exist with the iOS version.

I presume you're playing files over UPnP from your media server, correct?
Does it make any difference if you play files stored locally on your phone?
Please try downloading an album to your phone, navigating to its location (browsing by album or by folder) and playing from there.

May 29th, 2017, 08:36 AM
No versions beyond 1.0.55 lite are reading any music files on my sd card. Using a Logic Gfive with 4.2.3 unrooted. Any suggestions?

Please clarify.

What is the expected behavior and what exactly you are experiencing?

If you are missing "Internal Storage" + "External Storage" in the initial screen, it will be back with the next update.
As for now you can add these back by hand, just go to settings / Media Library and set the correct folders there.
If you wish some folder to be shown among your music folders but not actually searched for music (for browsing by artist/album/etc), you can now keep a folder listed but toggled "off".

May 29th, 2017, 09:10 AM
Yes music is played from NAS using UpNP/ DLNA. This still has issues playing using v1.0.78 beta on android.
So downloaded 20 tracks of lossless FLAC from the NAS to the phone SD card and this plays with no problems when using v1.0.78 beta.
Still no problem playing the same NAS FLAC music files using iPad at v1.0.76 beta.
The rgm831 post maybe should be in a separate post to avoid confusion.

May 29th, 2017, 06:05 PM
Just wanted to add that mconnect app can play same music files from the NAS ok.
This morning I was swapping between Foobar2k and mconnect ( closing one then opening the other ) on the android phone and the playback issues were only with Foobar app.

May 29th, 2017, 07:26 PM
Got my son to load Foobar2k v1.0.71 lite onto his Huawei android phone.
Playing tracks from the same NAS with no issues except the problem of not displaying all files like I had on my Samsung before going to v1.0.78 beta.
Other details that may or may not be relevant / helpful:
Router is an ASUS RT-AC88U - NAS is directly connect to a gigabit port on this router. NAS is set with a static IP address.
Tried optimizing QoS on the router- no change. Current QoS is set to off ( default ).
Problem still there with even though I now have the NAS connected only to the Router with no other devices connected.
So testing this issue with as simple as possible. Network looks like:
NAS--cat6 cable-->ASUS Router------ wifi 5G------>Phone---bluetooth----> to speaker
Next thing I will try is using a separate TP Link wifi access point and take the router from the equation when I get some time today.

May 30th, 2017, 03:47 AM
Ok..when using the Samsung S5 with v1.0.78 beta and using the NAS simply attached like:
NAS---cat6 cable--->gig switch<---cat6 cable TP Link wifi Access Point and using the phone wifi to link to this separate network via the access point ( ie no router ).
The TP Link Access Point is not needed when using the ASUS router so is not normally connected.
With the router out of the network for this test I find that instead of being able to select by folder or albums or artists etc I am only given a choice of by track and given I have almost 41000 tracks it takes a while to present them.
With a router in the network and v1.0.78 beta allows me to select from artist or album or folder etc as normal.
This does not happen with v1.0.71. v1.0.71 allows me to select from artist or album or folder etc. whether using the normal router based network or the test network using the TPLink WAP.
I find it a little more stable than when using the router setup as described in the last post ie: NAS--cat6 cable-->ASUS Router------ wifi 5G------>Phone---bluetooth----> to speaker
I then found another old Samsung GT9500 phone and downloaded Foobar2000 mobile v1.0.71. This appears to be more stable when used with either setup. Not perfect just a couple of very slight / brief stops in the music over now a hour period. Nothing like the regular stops with v1.0.78 beta.
So my observation is that android v1.0.78 beta is problematic with periods of the music stopping ( even the time count stops ) and resuming after a few seconds from where it stopped.
Android V1.0.71 is much more stable with both the Huawei or Samsung only issue with that is the indexing of the complete music file list.
So I am wondering if you are able to reproduce this in your environment or is this only happening to me?
From memory my problem with not displaying all the Artists/tracks etc happened between whatever release I was using before v1.0.71 was installed.
Hopefully my description is not too confusing...
Luckily the iPad still plays well with the beta code v1.0.76 and sees all the artists and tracks. I mainly use the folder option.

May 31st, 2017, 07:25 AM
Please check 1.0.80 beta with a new "read-ahead buffer" toggle in advanced options; enabling that option should help with playback issues over network foobar2000 will try to keep several megabytes of data buffered ahead of current playback position.

June 2nd, 2017, 01:18 AM
Sorry to report...
Tested over a few hours today with the new parameter active.
V1.0.80 beta while a lot better better than v1.0.78 beta still:
1.Takes between 10 and twenty seconds before a track plays after selecting it
2. Pauses playing a track on average once or twice per track. Sometimes 30 seconds into it and sometimes a few minutes into the track. Track time stops then restarts when resuming not missing any time on the timer. ie pauses at 0:41 then when it resumes continues on from 0:41 onward till the next pause.
Pause usually for 5 to 20 seconds.
Tried also with OpenSL on and off. No change. But the new "read-ahead buffer" option certainly improved the issue but unfortunately there is still an inherent issue with the android build ( or some sort of incompatibility with the phone for whatever reason ).
I also tried playing with a LAME 320kbps selection of music with the Samsung phone (at v1.0.80 beta ) just in case lossless files were possibly interfering in some way.
Playing the LAME 320kbps music was from a USB drive via the ASUS routers USB3.0 port ( DLNA/UPnP) No change to the pausing problem when using the LAME 320kBPS version.
Have reverted back to the iPad using Foorbar2000 at v1.0.76 beta which is sounding good.

June 3rd, 2017, 02:51 AM
When you ask foobar2000 to download files from your music server, how long do they take to download? Does downloading take comparably long - or even longer than the playback time of those tracks?

Are other apps on affected phones able to play your music without issues? Try BubbleUPnP (https://play.google.com/store/apps/details?id=com.bubblesoft.android.bubbleupnp) for an example.

I also use Asus routers personally and have mixed experiences with them.
My office runs on RT-AC68U and it's the most stable thing ever, excellent range and throughput.
A few months ago I bought RT-AC87U for my home - and it turned out to have been a horrible idea, after much hair loss and blasphemy I narrowed its extreme packet loss problems down to the 5 GHz band. Once I got all my devices on the legacy 2.4 GHz band, all my strange connectivity issues were gone. I now run the RT-AC87U with 5 GHz network disabled entirely. Perhaps you should cycle the affected devices between 5 GHz and 2.4 GHz networks of your router?

I've just conjured up a similar bug on my own home setup-
One of my devices drops wifi to ridiculously low speeds with a bluetooth headset active. Not just foobar2000 is affected - also web browser, Google Play, etc.
Perhaps bluetooth being on/off is a factor to this?

Note that there's no way foobar2000 mobile for Android networking behaves totally differently than its iOS counterpart, their network implementations are practically identical.

June 3rd, 2017, 08:34 AM
Thanks for the update.
They did take a long time to load initially.
Yes to date I have been running the wifi on the 5GHz band.
The RT-AC88U has quite a very good coverage in and around my property but have been doing this testing no more than 10 metres from the router.
You are right the 2.4GHz band loads the tracks faster.
Will do more testing tomorrow and run it at 2.4GHz for a few hours and see how it goes.
Although I have been using the iPad on the 5GHz band also..with none of the issues the android was experiencing as far as pausing was concerned.
The 2.4GHz AND 5GHz band are using the same options/ parameters.
I will also experiment with some of the parameters in the router such as beamforming etc on the 5GHz band and see if there is any effect.
Maybe even try the WRT Merlin firmware.
But certainly 2.4GHz with the android has had only one very short pause after playing for 45 mins but unfortunately I have other commitments tonight so will get back to it tomorrow but thought Id do a quick update.
A step in the right direction though.
One other thing I noticed that even at 2.4GHz if I'm playing a track and forward to the next track it does take about 5 or 6 seconds before the next track starts.
Also I will go back to the separate wifi set up with the TP-Link WAP and remove the router from the equation. Have not tried this at v1.0.80 beta yet.
Thanks again for your patience with this.

June 3rd, 2017, 11:12 PM
Was still getting a very occasional pause even on 2.4Hz over a few hours playing.
The ASUS router was basically at default settings for the wifi except for SSID and password etc for both 2.4GHz and 5GHz.
1. Made some changes to the settings of the ASUS RT-AC88u based on the following article that was not necessarily aimed at the model I'm using but generally for ASUS routers wifi:


2.In addition I changed also Wireless menu >> Professional Tab >> Airtime Fairness after reading this article


Many thanks to these guys. Got to love the good parts of the web.

3. Also decided to use the ASUSWRT Merlin firmware 380.66_4.

Music has been running with stability on 5Ghz for about 2 or 3 hours from the NAS through the ASUS router.
Have not detected a pause so far even though it is using the 5GHz Wifi.
Still using the OpenSL and read-ahead buffer setting on Foobar2k.
But certainly the changes made to the router has made a vast improvement as far as the android is concerned at v1.0.80 beta.
Will continue listening on android at v1.0.80 beta for the rest of the day.
Will re test the iPad tomorrow and see if all is still ok at v1.0.76 beta.
I am surprised that the iPad had no issues along the same lines as well but I guess that's trouble with so many dependent variables with regards to comms complexities.
Probably why others have not been reporting the same issue with pausing.

June 4th, 2017, 04:33 AM
Just updating..Played music for 7 hours total today without any pauses while playing from the android on the 5GHz band with the changes above.
When I get a chance over the next few days I will see if the iPad Mini still works well with the current router changes.
The original issue of not displaying all files is also ok at v1.0.80 beta also.

June 5th, 2017, 04:40 AM
iPad Mini at v1.0.76 beta running on the 5GHz bandwidth ran with no issues for 2 to 3 hours today.
Thanks again