Results 1 to 2 of 2

Thread: Album metatags not updating if album is already on iPhone

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Album metatags not updating if album is already on iPhone

    Pretty much as above.

    My phone is an iPhone 11 Pro.

    I went through & re-wrote all the tags to a large set of albums in iTunes, to make use of the way that foobar sorts albums. Which is to say that foobar sorts albums by title - as you'd expect - & I had previously used sort fields for this particular batch of albums, which foobar doesn't recognise.

    Some of these albums were already on the phone & others were added as part of this recent sync.

    Having finished the sync, all of the new albums are showing the new title, but the albums that were already on the phone have not updated at all & so are still sorted by the previous title.

    I've tried going into the media library folder & re-scanning, but that doesn't fix it.

    Anything else I can try before I re-sync to nothing & then put the entire library back on again?

  2. #2

    Re: Album metatags not updating if album is already on iPhone

    So, no replies to this, but further to what I wrote initially, I've noticed the following:

    I ripped a box set of Wagner operas & used a generic image for all of them in dBpa.

    I batch converted to m4a & synced with my phone. Now, if I go to Composers > Wagner & see all the Wagner albums, all the albums from the box set have the generic cover, as you'd expect.

    I then went through, in iTunes, & changed the sleeve artwork for each of the operas so that the each now had a unique sleeve. When I re-synced, the Composer > Wagner "list view" still showed the generic sleeve across all the albums but when I clicked on the album to play it, it shows the unique sleeve.

    The only way I can get the Composer > Wagner "list view" to show the updated sleeves is to remove Wagner & sync, then re-add Wagner & re-sync. Which is quite time consuming, as you can imagine.

    I'm not sure if this should go down as a bug or not, but there it is.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •