Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Fb2k, android 10.0, permission denied error

  1. #11
    Member
    Join Date
    Jul 2014
    Location
    NH, USA
    Posts
    16

    Re: Fb2k, android 10.0, permission denied error

    ok, I will give it a try...

    EDIT:
    I just tested Foobar2000 Mobile ANDROID v1.2.0_Beta 5
    and its working!! ^_^
    thx so much Peter!
    Last edited by Melchior; January 7th, 2020 at 09:28 AM.

  2. #12
    Member
    Join Date
    Jul 2014
    Location
    NH, USA
    Posts
    16

    Re: Fb2k, android 10.0, permission denied error

    Peter, so what was wrong with Foobar2000 Mobile?

  3. #13
    Administrator
    Join Date
    Feb 2014
    Posts
    435

    Re: Fb2k, android 10.0, permission denied error

    Google Play is forcing newly submitted apps or updates to be built with latest security features enabled (target API level of 28 or higher).
    Source: https://android-developers.googleblo...uirements.html
    foobar2000 mobile series 1.1 was targetting API level 26 (and it can no longer be updated via Google Play because of that).
    foobar2000 mobile series 1.2 targets API level 29. It by default enables new filesystem sandboxing features, which were getting in the way. For some reason this did not cause trouble on my Nokia phone running Android 10, but seems to prevent SD card access on other phones. I added a manifest flag to opt out of the sandboxing until I can figure this out properly, so everything again works as before.

  4. #14
    Member
    Join Date
    Jul 2014
    Location
    NH, USA
    Posts
    16

    Re: Fb2k, android 10.0, permission denied error

    Thanks Pete for your reply and heads up..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •