Results 1 to 3 of 3

Thread: iOS 10 first run experience glitches

  1. #1
    Join Date
    Feb 2014

    iOS 10 first run experience glitches

    I've noticed that iOS 10 - on first app startup - asks you if foobar2000 is allowed to index its device's music library. It also makes foobar2000 think the device's music library is empty, because first time we ask for the music library content we get nothing. iOS also doesn't give us "music library has changed" flag when the user approves access, so you have to go to Preferences / Media Library and manually hit "refresh" in order to get your library content shown again. Killing and restarting foobar2000 should fix it also, as it will make foobar2000 ask iOS for music library content again.

    This will be somehow addressed in a future update as it must be extremely annoying on new installations, not seeing any music at all on fresh install first run.

    On first run some of your music may be missing from foobar2000 library; manually refreshing the library (Preferences / Music Library) or forcibly restarting foobar2000 fixes it.

  2. #2
    Join Date
    Jun 2016
    San Diego, CA

    Re: iOS 10 first run experience glitches

    It's working fine for me. Added more music to it today and it's all seen. Are you trying to scan your iTunes library or is it looking at documents? Since I play only FLAC files, they're installed as documents... could be the difference.

  3. #3

    Re: iOS 10 first run experience glitches

    Yes, he is referring to the app granting itself the permission to read the iTunes Library. And as the lead developer, he felt the need to warn people of this potential issue, until it is solved, if it may even be solved.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts