Results 1 to 3 of 3

Thread: [Bug] UPNP playlist DNS issue

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    [Bug] UPNP playlist DNS issue

    Using the foo_UPNP component in foobar2000 desktop as my UPNP server, if that's relevant.

    Because populating a remote playlist takes more than a few seconds, I add all items in a remote playlist to a local playlist. This way I can easily open the foobar2000 mobile app and start streaming.

    However, I can not create these playlists when connected to my LAN, or the playlist entries resolve to 192.168.... which will not work outside the LAN.

    From this information, I can think of two potential causes.

    1. The "User Specified Server" item just redirects me to the detected "Local Network" UPNP server and all my actions are taking place in that context without my knowledge.

    2. The creation of playlist items resolves DNS in such a way that "Local Network" is detected and preferred.

    Either way, this is undesirable in all contexts. Premature optimization is the root of all evil
    A hypothetical user wants to stream over WAN when away, but LAN when home? Any [sane] router will internally loop back "Remote" requests where the destination is its own WANIP, it does not make sense to have the app prefer Local when Remote is available.

    Thanks

  2. #2

    Re: [Bug] UPNP playlist DNS issue

    Alternatively, could we use a playlist format that supports domains and doesn't need to prematurely resolve DNS?

    I observed this on the Windows 10 mobile app on a Windows 10 mobile phone.

  3. #3

    Bug UPNP playlist DNS

    AIMP v4.10.1827:

    Options -> Playlist -> Appearance isn't showing the list elements of tag macros / variables.
    None of the 3 contextual dropdownlists is showing any values...

    Images describing the visual bug, attached.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •