Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Couple of Android/FiiO issues (library, playback)

  1. #1

    Couple of Android/FiiO issues (library, playback)

    I'm using foobar for android on the fiio x5 3rd gen and although for the most part it is working fine, I am having a couple of issues.

    • Since the upgrade to 1.0.71, library indexing has slowed down dramatically. At the moment, my library has 36475 tracks. On 1.0.63, this takes less than ten minutes to index (which is pretty impressive) but on the upgrade it gave up after about 40 minutes and ~22000 tracks. Reverting to the earlier version has solved the problem but is obviously not ideal.
    • Although it isn't happening every time, after the majority of albums finish I'm having an issue whereby when I select another track/album playback doesn't work properly. Instead of playing as expected, there is no audio and the selected track will appear to fast forward or play at an increased speed (not really sure how to describe it other than to say imagine the track is playing at about 30 seconds per second)
    • Probably a device specific problem but the physical play/pause button will pause correctly every time but sometimes when re-pressing to play again it will restart the current track. If I press play using the touchscreen it plays correctly. Outside this issue the buttons seem to work fine but if it helps, when I tried Poweramp on the device, the buttons only worked properly when I setup wired headset buttons to "single press (fast)"


    Other than this, I really like the app. I can't find any other app that works on the device that comes close to matching the variety of library browsing options in foobar.

    Obviously I understand that these could be hardware issues but it would great if anyone could help anyway.

  2. #2
    Administrator
    Join Date
    Feb 2014
    Posts
    429

    Re: Couple of issues android issues (library, playback)

    Thanks for the problem reports.

    The slow indexing is inflicted by Android's Storage Access Framework (SAF) used to access external storage in the new version.
    You can go around it (but you will lose write access) by going to advanced settings, toggling "use old folder picker", removing library folder and adding it back.

  3. #3

    Re: Couple of issues android issues (library, playback)

    Thanks. That worked.

    I should have mentioned on the second problem that the only way to get music to play properly again is to completely close foobar and then reopen it.

  4. #4
    Administrator
    Join Date
    Feb 2014
    Posts
    429

    Re: Couple of issues android issues (library, playback)

    The second issue-
    Did you by any chance flip the 'Use OpenSL' toggle in Advanced?
    Whatever its state is, please try the opposite mode.

    For reference, OpenSL is known to be unreliable for music playback on many devices and cannot be enabled by default, but it may help if the default output mode (Android AudioTrack) is behaving incorrectly - at least it avoids piping all your sound thru Java code.

  5. #5

    Re: Couple of issues android issues (library, playback)

    That does appear to have fixed to the second problem. Thanks.

  6. #6
    Administrator
    Join Date
    Feb 2014
    Posts
    429

    Re: Couple of issues android issues (library, playback)

    Which way does it work properly for you, OpenSL disabled or enabled?

  7. #7

    Re: Couple of issues android issues (library, playback)

    Enabled

  8. #8

    Re: Couple of issues android issues (library, playback)

    Hi again,

    I happened to spot on the dev blog entry that the "old folder picker" option shouldn't be needed again after 1.0.78 so after updating to 1.0.79 I decided to give it a go again, turned the option off and had the same problem as I described above with the library indexing getting stuck this time at ~27000 tracks after about 45 minutes. Turned the old folder picker back on and it's still working quickly and correctly. Not sure if I've misinterpreted the dev blog but I thought I'd mention it in case I hadn't.

    Also, I think I've noticed a pattern on the third problem from my original post with the play/pause button. I can't say for certain if it was the same in the previous version but it appears that the issue is only happening with files on the second sd card. To be clear the device has two sd cards. Using the old folder picker option the first sd is added to Music Folders as the "External Storage" option and the second is a manual path of "/mnt/external_sd2". When songs on the first card are paused they resume without issue. Songs on the second SD seem to bring the screen back on, play for a second then the lock screen notification briefly disappears (like the app is restarting), reappears and then the track starts from the beginning.

  9. #9

    Re: Couple of issues android issues (library, playback)

    On this play/pause error again, I've just had a look at the console after what I described above as "like the app restarting" and it does indeed appear that the app is restarting.

    I've also noticed, once more only on the manual path card, that sometimes when I try to restart playback it won't restart at all, even from the start and when I try to select any other track it won't work. I've tried closing the app and force stopping the app but the only solution that works in this situation is restarting the device. Not sure if it's true for both issues but certainly on this one when I look at the console I'm seeing a message "Playback error: Access Denied".

    I've tried swapping the cards over and the issues are only happening on the manual path card which suggests to me that it isn't an issue with the actual sd cards

  10. #10
    Administrator
    Join Date
    Feb 2014
    Posts
    429

    Re: Couple of issues android issues (library, playback)

    Just a heads-up: I have a FiiO x5 3gen unit now and have been able to recreate some of these bugs already. The next update will deal with them.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •